Get in touch
Back
Maintenance

Service upgrade and general maintenance

Completed 25 Jun at 09:15pm CEST.

Website & Widgets (subathon-royale.com) Timer, Chat Bot & API (api.subathon-royale.com) Twitch Chat Connection
Completed

Maintenance completed

Posted 25 Jun at 09:15pm CEST.
Started

The timer and website will be down to roll out a new update and perform some general maintenance

Posted 25 Jun at 08:35pm CEST.