Get in touch
Back
Maintenance

Server Maintenance

Completed 8 Aug at 12:51am CEST.

Website & Widgets (subathon-royale.com) Timer, Chat Bot & API (api.subathon-royale.com)
Completed

Maintenance complete, all services should be available again

Posted 8 Aug at 12:51am CEST.
Started

Services might be temporarily unavailable

Posted 7 Aug at 10:15pm CEST.